LESS in the SAP web IDE

Discussion Forum SAP Fiori Design LESS in the SAP web IDE
Viewing 4 posts - 1 through 4 (of 4 total)
UI&UX Design consultant
SOA People Nederland N.V.

Hi all,

Because in some custom projects I like the use LESS over CSS to keep it more lean.
lately I saw in my build console in the webIDE a new experimental feature:

data-sap-ui-xx-lesssupport = “true”

Which would assume you could use LESS directly as in the UI theme designer instead of compiling it every time. This would of course save some time. Now my questions is how do you activate this? I added the part to the bootstrap as the console.log noted. But I can’t find any documentation about this feature. Is it already functional? Do I need to configure more? I added the resource also to the manifest, but that doesn’t seem to make any difference.

Thanks for answering!

UI5 Core Developer
SAP SE

Hi Rick,

 

could you please explain the context you are referring to? Which project are you developing in the WebIDE? Is it a SAPUI5 Library?
The xx-lesssupport parameter activates a client-side LESS compilation which is intended to be used for library development without a server which is capable of compiling the LESS files on the fly. It will check whether CSS is available and whether it is newer than the LESS files and depending on this, activates the Less Support. There is no further configuration.

As you already mentioned, this is an experimental UI5 feature and I’m not sure where this is currently used in the WebIDE.

 

Best regards, Matthias

UI&UX Design consultant
SOA People Nederland N.V.

Hi Matthias,

Currently i’m working on an SAPUI5 app in the webIDE. By using the latest version of SAPUI5. when exporting my app for a native app my console noted I was using a less file besides my css file. So I was curious about this function, because it seems not functional yet and I couldn’t find any documentation either.

So I was just curious maybe somebody here knew anything more overhere. and maybe some way to activate this function as early preview

UI5 Core Developer
SAP SE

Hi Rick,

as far as I know there is currently no LESS support in WebIDE and I’m also not aware of any specific plans, but I’m not directly involved into the progress there.

Best regards, Matthias

Viewing 4 posts - 1 through 4 (of 4 total)
 

You must be logged in to reply to this topic.